ニコニコ動画アワード2010

予想(期待)通り、bad apple!!がグランプリ受賞となったそうだ。
とは言っても発表前日に友人に教えてもらったくらい、情報は遅かったのだが…。

これの良いところは、元々の映像作品がすばらしい出来なのでそちらばかり見てしまいがちだが、カメラワークや照明などをコマ撮りにあわせて変化させているところだ。

上記が元動画。
元画像のモーション(フレームやキャラクター)を利用している、あるいはVEとしてコマ撮り映像にさらに味を加えているのが良い。
単純なコマ撮りに終始しているわけでないのだが、コメントにはたまにその視点が抜けている言葉を見かける。
ただのコマ撮りならパクリだし、コマ撮りアニメだし、それなら元動画でいいじゃん、となるがそうではなくて、全体を見てみないと。
例えばカメラのピンや照明の白飛びが見ていてよくわかる。
それをリアルタイムではなくてコマ撮りで表現しているのが良いのだ。
諸手を挙げてと言うわけではなくて、出だしあたりのブレ方が荒さを感じるのだが、トータルでその努力は賞賛(グランプリ)に値すると…。

でも、今回の件で初めて知ったのだが、動画やコマ撮りのそもそもの元になる絵コンテ(字コンテというらしい)があるという驚きの事実。

ほんとなのだろうか?
何せちょっと前にグランプリのことを知ったというくらいなので、よくわからん。
これが事実ならニコニコ動画というのはおもしろく魅力のある世界だと思う。
そう考えるとオリジナルも派生も含めて、東方に関わる人たち全てに向けての受賞なのかなと思った。
ちなみに、東方(シリーズ)というのも今回初めて知った。

驚きと言えば下もそう。

すごいです。 😯
…。

これもおもしろかった。

ネコもいいが、コメントにある訳(空耳)があって、おもしろさが成り立っている感じ。
なんとなくそう言っているように、いや、そうとしか聞こえないのだが…。

CPUクーラーに相性?

相性というのは何とも魔法な言葉で、それを言えばうまく完結するように広がっている。
実際は必ず原因があるわけで、それをうやむやにして、ほっといておく方にメリットを求めるため成り立つのだろう。
その一つが以前購入したzotacのgeforce6100-itx。
6100-e-eとも言うのか?
これが何とも挙動不審なのだ。

通販で購入後、早速起動。
ところが起動しない。
PostもBIOSすら写らない。
何度やっても同じ。
液晶の電源ボタンが入力の有無を示すのだがそれが変化無く、そもそもディスプレイ出力がされていないようである。
CPUを変えても同じ。
メモリを付け替えても同じ。
電源を変えてもやはり同じ。
HDDなんて当然つけていない。
もはや外すものがないわけだ。
で、以前経験した「BIOSが吹っ飛んだ」件を思い出して、てっきりBIOSが逝かれたのだろうと思った。

早速A社に連絡して返送。
ところが、「問題ないですね」との返事。
「負荷を一晩かけ続けても問題なかったです」とのこと。

再現性がないわけない。
後日戻ったものに早速最小構成で挑むもやはり駄目。
駄目でも何とかなるもので、何かの拍子でBIOSが出てきた。
店で動いてここで動かないはずがない。
もう何が原因かなんて気にするまい。
これがないとパソコン動かないんだから。 😕
結局こわごわとであるがそのまま運用し、先日まで問題なく動作していた。

で、先日のWHS用のテストである。
早速電源を入れるも動かない。
以前と同様の症状だ。
前回さんざん苦労したのでやや涙目であるが、ともかく動かさないとただのゴミ。
前回と同じことをしても無駄と悟り、たまたまであるが、CPUクーラーを変えてみた。
するとモニターにBIOS設定が写るではないか。
そういえばA社の人が「クーラーにも相性がある」みたいなことを言っていたのを思い出した。
そんな馬鹿な、と試してなかったが本当だった。

でもおかしい。
動作したのは社外品。
AMD純正同梱のクーラーでは駄目なのか?
しかも2個ともAMD純正だったが駄目だった。
相性じゃないだろう?と試しに純正クーラーを固定せずに起動してみた。
なんと! ❗
写るじゃないか!

Postを写したままクーラーのテンションをかけてみる。
画面が滲んで、キーボードからの動作を受け付けない。
その状態で電源を入れ直してみると、また写らなくなった。

今度はゆっくりとテンションをかけて、どこで止まるか見てみた。
クーラーを固定する金具はテコのようになっており、一定の場所からテンションがかかり始める。
そのまさにかかりはじめたところから、画面がぶれ始めた。
その状態だとまだ操作を受け付けるようだし、起動もしている。
さらにテンションをかけると、動作ストップで画面真っ黒。

こんなことは初めてなのだが、テンションかかるとマザーがゆがんで、どこかの結線部が剥離するのではないだろうか。
それ以外に考えられないのだが…。
というかAMD純正クーラーで再現できるのなら、疑問も湧く。
A社よ、なぜ純正で試さなかった?
純正状態で再現を試みて欲しかった。
これってやっぱり初期不良ではないのだろうか。

値段が値段なのでこのままだまし続けて使うことにする。
安全性に疑問があるが…。

vistaのHDD載せ替え

vistaの載ったHDDのマザーボードを交換する話。
windows2000の頃だったと思うが、当時何度かマザーの交換をしていた。
安定性を求めた故だったと思う。
xpではHDDのデータを整理するためクリーンインストールをするばかりになり載せ替えはしたことない。
WHSはここ数日で経験したばかり。
2000の時は特段問題も発生せず、載せ替えてからドライバを当てればきちんと動作した(はず)。
まれに載せ替えるとディスプレイ出力がなかったりしたが、元のマザーでいったんドライバを消してから再度載せ替えたらうまくいったこともあったかな。
すっかりわすれてしまった…。
ちなみに、WHSの場合は一度認証してしまうと、「ハードが替わりました」と言っていちいちライセンス認証を通さないとログインできず何もできないのでちょっと面倒。
というのもログインできないとイーサネットのドライバを当てることができないので、オンライン認証ができず、認証しないとログインできないという循環になるため、電話認証しなければならないからだ。

それはさておき、都合上パソコンのマザーを変えることにした。
対象はvista。
簡単に終わるだろうと思ったら起動途中のスクロールバーでリセットがかかる。
無限ループ…。

早速調べる。
先人の知恵にあやかるのです。
[Vista] OS再インストールなしにマザーボード交換Vista編 速報版
これによるとvistaでは…、
**********以下引用
4.次のレジストリ サブキーを見つけてクリックします。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
**********以上
のようにレジストリを書き換えておく必要があったらしい。

そこで元のマザーに戻してregedit。
移行先のマザーはD525MW。
インテルなので Intelide.sysも0に変更。
でもよく考えたら、過去のトラブルの禍根により使用中のHDDはAHCIをひとつとして適用していない。
Msahciは設定要らなかったかも。

再度マザーの載せ替えをして、起動。
シークバーもクリアして正常に起動した。
あとは添付CDのEIProcessCaller.exeを起動してドライバを当てるだけ。
簡単であった。
多謝。 😮

whsのマザーを検証

HDDの不具合により大量のデータをサルベージするのに四苦八苦した。
そもそも古いマザーを使用しているのが元凶なのか?と疑い始めた。

そこで、現在のpentium4 1.6GHz以外で適したマザー(CPU)があるのかちょっとだけ検証してみた。

候補は最新のatomとmini-ITXなAMD。
1.cpu : pentium4 1.6GHz M/B:GA-8VM800M
2.cpu : atom D525 M/B:D525MW
3.cpu : BE-2300 M/B:6100-itx

*
*
まずは電力測定。
WHSインストール済みのHDDをそれぞれのマザーに取り付ける。
ストレージはHDDの二台のみ。
負荷は起動時のピークを読む。
測定はいつものごとくクランプメーター(正確な消費電力はわからないが、傾向や比較はできる)。

1.負荷0.5A アイドル0.3A
2.負荷0.3A アイドル0.3A
3.負荷0.5A アイドル0.3A

電力消費量はあまり大差ないがatomは負荷がかかっても大きな変化がない点ですばらしい。
ファイルコピー中などは負荷がかかるので、大量のファイルコピーがある状況では電力消費の累計が大きくなるだろう。
*
*

*
*
次はネットワーク転送速度。
サーバとしては重要な部分。
タスクマネージャのネットワーク使用率を目視確認。
XP→WHS。(共有フォルダへ2Gのファイルコピーを5回以上断続的に試す。)
全てGbE。(1.pentium4 にはPCI接続のもの。2と3はオンボード)

1.30%強で安定。
  まれに20%台でふらつく。
2.20%台。
  転送開始時には50%まで伸びるがその後遅くなる。ごくまれにコンマ以下に落ちる。
3.20%後半を基本。
  転送開始時には50%まで伸びるがその後遅くなる。

最初はジャンボフレームの設定をしていたのだが、各々でコンマ以下のネットワーク使用率になってしまうことが増えてきたため、基本的に使用しないことにした。
1.はほぼ一定で一番安定しており、2.は20%後半で安定することがあれば、前半で安定することもあった。
3.はたまに30%台に乗せることがあったので、1.と同じように安定していると言える。
2.でコンマ以下に落ちることがあったのは、もしかしたら何かWHSが動作していたのかも。
2と3で転送開始時や途中で50%台に伸びることがあったが、長続きしない。

逆にいえば、まだネットワーク使用率の向上が見込めると言うことだ。
*
*

*
*
そこでFire File Copy v4.9.1を試してみた。
Fire File Copy

1.30 40%前半。
3.90%前半。

1.は変化が見られない多少使用率が上昇しているのに対して、圧倒的に3.がすばらしい。
2.はパソコン使用のために検証から抜け出さざるを得なかったためデータがないが、推測では3.と同じような良い結果が見込めるのではないかと期待している。
結果に対しスペックを考慮すると、もしかしたらCPUパワー(コア数等)が関係しているのかもしれない。(送信元XPは3コアのphenom720BE)
その辺はFFCの解説にあるだろう…、きっと。 😐
*
*

どう考えても2か3の選択が正統派だと思うのだが、バックアップは基本夜中であるから転送時間は無視できるし、長いのは初回バックアップ時くらいだし、FFCでの転送は使用場面が限られるため、やはりこのままpentium4を使い続けることにする。
次期WHSvailは今の状況では64bitCPUでないと動作しないかもしれないので、まぁOSを更新するのがいつになるかわからんが、それまではpen4にがんばってもらうことにしよう。
そういえば何でこんな検証したんだっけか?
まぁいいや。 😉

共通して残念なことは、スクリーンショットや写真を一枚も残していないこと。
手書きデータだけだと、今こうやって思い出しながら書く際には詳細まで思い出せないし、客観視しづらい。
次やるならちゃんと写真くらいは残しておこう。

フロントUSBの不具合

以前にも書いたかもしれないが、パソコン筐体フロントにあるUSBに大容量のUSBメモリーを直接つなげると、転送途中で止まってしまう現象がある。
そのメモリを本体裏のUSBコネクタにつなげると、これはちゃんと動作する。
そういえばフロントとリアでは転送速度も若干違うような気がする(確証なし)。

不思議なのは、直接接続だと止まってしまうフロントでもUSBハブを介してUSBメモリへ転送すると正常動作するのである。
リアにつなげたときでもUSBHDDを認識しないときがごくまれにあるが、そのときもハブを経由すると認識することがある。

まぁそんなものかなと考えてフロントUSBを使うときはハブを使うようにしてきたわけだ。
だが、所有するマシンの中で、メーカー製以外のパソコンはどうやら同じ症状があることに気づいた。
フロントはマザーボード基板上のピンにコネクタ端子を差して使うのだが、もしかして何かBIOSで設定があるのか?と思い、所有するマザーのマニュアルを見てみた。
しかし、シャットダウン後も給電するためのジャンパが基板上にあるという説明くらいで、BIOSの設定では見あたらない。
中にはBIOS設定項目の記載すらないマニュアルすらある。
それはともかく、専門用語英語は理解に苦しく、もしかしたら見逃しているのかもしれない。

ただ一つ言えるのは、ハブを使えってことか。 😐

wd20eads と whs の相性か?

不良セクタが大量に検出され、whs自体のI/Oスピードが落ちてしまう事態に困り果てた。
前回疑ったadvanced formatはこのeadsとは関係がないし、そもそも見もしないでearsが載っているものだと思い込んでいたため余計な考察をしていただけで、当然原因とはならない。
しかも、保証期間がわずか2週間前に切れており、もはや回復する手段は試したことがないRMAのみかと落胆。

試しに2度wd20eadsにwhsを新規インストールをしてみた。
一度目はSATAケーブルを付け替え試す。
二度目はマザーをatomに変更して試す。
が、やはり不良セクタの山は不動だった。
1932531142KB(容量)
879762156KB(不良セクタ)
この数字は最後にインストールした時のchkdskの結果。
全てがこの数字だったかは記録していないので定かではないが、先頭の87…の部分は同じだったと思う。

仕方ないので、ともかく原因を調べるしかない。
WDのソフトウェアダウンロードサイト
上記のサイトでData Lifeguard Diagnostic for Windowsをダウンロードして、whs上で走らせた。
quickはpassした。
advanceextendedは検査時間約7時間の後、pass。

意味わからん。

実はこのWDの検査の前にHGST(日立)のDrive Fitness Test、CDブート版(CDimage/ISO)も試していた。
hitachiのソフトウェアダウンロードサイト
これまた同じく検査の時間は長かったが、やはりadvancedが通った。

保証があれば購入店で検査してもらえたかもしれないが、保証期間外の今では第三者のチェックが望めない。

チェックディスクそのものが不良セクタを量産してしまい、実は疑ってかかった転送速度低下の原因はHDDではなく他にあったのかも、などと考えてしまう。
ドライブの相性なんてあるのだろうか?
OSとHDD?
コントローラとHDD?
サウスの熱暴走も考えたが、触ってみてもぬるい程度だった。
試しにwd20eadsにXPをインストールしてみたが、チェックディスクは問題なし。
でも、今思えばXPのシステム(2GB)程度ではデータ量が少なすぎかもしれなかったな。
<追記:よくよく考えれば/Rオプションはつけてなかったかも…。覚えていない…。あるいは検出されていたかも。よって参考にならない。>

理由のわからない今、所有中で最大容量のHDDはWHSのシステムディスク、データディスクとしては使えそうにない。

< 追記:20101225>
上記の経過後の続き。
テストをパスしてしまうので判断に困った末、write zeros to driveで0書き込みをやってみた後で再度インストールしてみた。
書き込みに7時間もかかった上にインストール時間もかかったが、結局不良セクタの数字は変わらなかったと徒労。

ちなみに、速度低下の前後でシステムはwd10eadsにしており、wd20eadsはデータディスクとして追加してあったもの。
チェックディスクで不良セクタ確認後のテストのためのインストールはシステムディスクとして試用。

結論は出そうにないが、相性ではなく単純な故障なのではないだろうか。
故障の疑いのあるHDDの現状を考えれば少なくともWHSはもとより、他のOSでも使用しない方が得策なことは疑いようがない。

WHSクライアントの再インストール

サーバの再インストールにより各パソコンのデータのかけらも残っていないわけで、バックアップを取っておかないと落ち着かない。
WHSでバックアップされていて助かったことがこれまでで数回あった。
特にVistaはインストールとその後のパッチ当てで時間を浪費してしまう。
だから早速コンソールの再設定。

コンソールからは今まで通りにパスワードを入力すればクライアントからサーバに入れる。
しかしコネクタ自体はつながっていてもバックアップ設定(対象)にはなっていないから、再インストールが必要みたい。
ちなみに、advanced admin consoleがあればわざわざサーバにモニターやらキーボードやらつながなくて便利なのだが、やはり最初だけはつけることにした。

programfiles の windows home server にはWHSConnectorInstall があるのでこれを実行すれば、connectorCD は要らないようだ。

転送速度低下の原因はadvanced formatか?

前回、不良クラスタの山ができあがってしまって、HDDが粗悪品だったとも考えられないし、まずは原因を調べてみることにした。
ネットワークの転送速度がたまに遅くなるというのはここ2,3ヶ月くらいのものだ。
だが、もしかしたらたまたま自分の使い方では速度低下の現象に直面しづらかっただけかもしれない。
そこでプロセスからひもといてみようと考えたわけだ。

demigrator.exeを一時的に停止できる?
上記を見ていてたまたま記述に目がとまった。
***************************以下引用
たとえば考えられる要素として一つ例をあげると、サーバーの記憶域にWDのCaviar Greenシリーズの2TB HDDが追加されているようですが、これはジャンパまたはAlign Toolを適用するなどのAdvanced Format対策は実施されていらっしゃるのでしょうか?
***************************以上
確か使っているのはWD20EARSだったか?
advanced format?
なんだ?

[FAQ] Advanced Format の HDD(Western Digital WD-EARS等)はWHSではサポートされません
まったくこの話は初耳だった。 😥
情報不足。
不良クラスタの原因はこれだったのかもしれない。

【WD20EARS】Advanced Formatを実装したHDDをXPで使用part1【Western Degital】
上記を見るとただジャンパをつけて短絡すれば良いだけみたいだ。
上の話でも動作報告があるらしいし。

ともかく設定してみよう。
しかし手持ちの中で一番大きい2TBのHDDに替わる空き容量のあるものなんてない。
というのも空き容量がなければハードディスク取り外しができない。
いきなり行き詰まった 😡

仕方ないのでHDDを2つ、データのバックアップ用にWHSに接続して、データをサルベージ。
個別のパソコンのバックアップデータは初期化喪失覚悟。
他のパソコンにもデータ転送して退避。
これが丸一日かかるほど低速。
データも大きかった…。
どうせはずせられないならと、転送完了してから試しにジャンパを装着してから、「ディスクの管理」でフォーマット。
コンソール上の表示ではデータ量や不良クラスタによるシステム容量に何も変化無し。
警告が「競合してます」とか「データを修復してください」とか何度も出る。
この後修復不可能でバックアップデータが元に戻らないことを知らされる。
ふぅ、…。

[FAQ]サーバーの記憶域からHDDを強制的に取り外す方法
結局上記を参考にして強制的にHDDを取り外すことにした。
**************************以下引用
6. HDDが特定出来たら、”xxxxxxxx-0000-0000-0000-000000000000″が対象のHDDを示すキーと
 なるので、
  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\
Disks\xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
 を削除します。
7. 6と同様に、以下のキーも削除します。
 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Volumes\xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
**************************以上
6の手順後、消してしまってからドライブがどれだったかわからなくなってしまったので、6と7は同時に行う気でいないと…。

WD20EARSの性能とAdvanced Formatについて
結局サーバに再インストールするはめになったが、上記の記事中に、「WD Alignはデータの記録位置をずらすことで本来の性能が発揮できるように調整されます。フォーマット後やセクターを含めたバックアップからの復元やクローニングの実行後にWD Alignを実行します。記録されているデータ容量が大きいほど実行には長い時間が掛かります。」とある。
もしかしたら、もしかするのか、と思ったがすでにフォーマット後だったので試せなかった。

たぶんHDDのパッケージにちゃんと書いてあったんだろうな。
なんも読まずにやるとこうなるってことですか。
もちろんadvanced formatが原因だと確定しているわけではないけど…、かなり濃厚。
リスクは分散させた方が良いと実感。

VT6421のドライバはどこ?

viaのVT6421のドライバを探していたが見あたらない。

VIA VT6421搭載インターフェースボード
SAPARAID-PCI

上記は玄人志向に掲載があったもの。たぶん5.4a。
下記がviaのダウンロードサイトで、確か5.5b(忘れた…)。
via arena

viaのサイトの方ではwhsあるいはserver2003のドライバがあるかどうかわからなかった。
結局適当なosを選択してダウンロードしたファイルの中に、2003のドライバフォルダがあった。
あって良かったけど、迷う書き方しないで欲しい。

最初に玄人志向のドライバを当てて再起動してみたがなぜか「動作していません」となった。
すぐにviaの新しい方を当てて再起動。
今度はちゃんと動く。

whsでチェックディスク

windows home serverで接続したハードディスク全てに対してchkdskを実行するバッチファイルの記事を見た。
[FAQ]WHSのエラー時にすべてのHDDにCHKDSKを実施する方法
****************************
net stop pdl
net stop whsbackup
chkdsk D: /x /r
chkdsk C: /x /r
for /d %%1 in (C:\fs\*) do start chkdsk /x /r %%1
****************************
上記のコマンドをそっくりそのままメモ帳で編集して、わかりやすい名前でcmdファイルとして保存。
これを実行するだけでchkdskしてくれるそうだ。
c:は当然ながら次回起動時にスケジュールするかどうか聞かれるが、それ以外は特にノータッチ。

私の環境ではたまにデータ転送やコンソールの反応が異常に遅くなることがあり、最近特にその症状が増えてきた。
それでこれを調べてみたわけ。
早速実行するとなんと 😯
不良(破損?)クラスタの山が…。
それまで空き容量が1.2TBくらい残っていたのが、クラスタ情報書き込み後は300GB程度に激減。
チェックディスクの最中にはコンソールに「空き容量が18GB以下になってます」的なことが一時警告された。

HDDはまだ購入後1年もたっていない。
原因はわからないがとりあえず取り外すことにしたが、空き容量が少ないせいでドライブの取り外し(削除)ができないよと怒られる。
仕方ないので寄せ集めたハードディスクをUSBやらSATAやらで追加。
フォルダの複製も解除してようやく取り外し作業を受け付けてくれた。
かれこれ4時間くらいたつがいまだ終わらず。