whs2011導入

これといって不都合のなかったwhs v1であるが、便利なサーバがさらに便利になるかもという期待を込めて更新してみた。
更新自体は大したことなく終了。
ごく普通にクリーンインストール。
動作もおかしいところはない。
少々操作性に戸惑いはあるし、項目の変更や項目そのもののないところもあって、少々旧OSが恋しい気分。

それに拍車をかけたのがバックアップ時間の異常な長さと失敗。
ダッシュボードはパソコンごとに同時に立ち上げておくと接続が解消されてしまうみたい。
おかげで300Gをバックアップするのに約一日かかったあげく、90数%のところで失敗となった。
涙でそうである。
というか前作よりもバックアップが遅いではないか。
まぁきっと初回だけだろうと思っていたが、他のパソコン(200G弱)でも12時間かかるなど正常動作とは思えない重さ。

そしてふと気づいた。
ダッシュボード上でハードドライブを眺めていたときである。
あるはずのHDDが認識されていない。
しかし別の時に再度チェックするとまた認識されている。
HDDがおかしいのだ。
そしてHDDのI/O異常によりシステムのI/Oが引きづられてしまう現象、確かこれは旧OSの時もあった。
WD2TB HDDの不良セクタ現出時である。

現在当該の怪しいHDDは外してある。
そしてWHS2011はすこぶる快調である。
バックアップ時間も20G(SSD64G)くらいの小さいものなら、初回でも20分強で終了したので、推測の域は出ないものの、現在は300Gでも早くバックアップできていたかもしれない。

vista再インストール

結局スリープの復帰動作が不安定なまま、今度はwhsのコネクタソフトのアンインストールができない症状にでくわす。
これができないとwhs2011への移行が完了しない。
一度古いソフトをアンインストールしてから新しいソフトをインストールするため。
アンインストールを開始すると途中で固まってしまうようだ。
修復も試みるが同様にストップ。

WHSコネクタを削除できない
イベントログを見て上記に近い気がするも当該ファイルが見つからないし、プロパティに異常は見つからない。
これまでvistaを極力避けてきただけあって情報も持ち合わせてないし、これ以上つきあう気すらない。

そこでvistaを再インストール(クリーン)することにした。
結果からいえば、もう二度とインストールなんてしたくない。 😡
sp適用済みdvdがあるのなら有償でいいから入手したいと思ったほど時間がかかった。
アップデートにつきっきりではないので気づいたときはたまにストップしていたせいもあるが、アップデート時間は24時間以上かかった。
実際アップデートを中断することなくすればたぶん最短で6時間くらいで済んだかもしれないが、つきっきりで対処するわけにもいかない。
インストール初頭から数えて再起動は20回以上。
涙が出そうな時間とエネルギーの浪費である。

だが、良いこともあった。
スリープの復帰に失敗することがなくなった。
ハイブリッドスリープでも失敗しない。
原因はわからない。
というか、これ以上振り回されたくない…。 😥
もういやvista。

キーボードで電源の管理

前回BIOSのメモリ設定をしたおかげで、長時間のスタンバイからの復帰に失敗することはなくなった。
ところが、今度は不意にキーボードを触ってしまうと勝手に起動してしまい、この場合は復帰に失敗する。
私はキーボードやマウスからの起動は好きではないので以前から無効にしていた。
なので、vistaでも同じようにキーボードの項目にある電源の管理をちょちょいと変更しようと思った。
ところが電源の管理タブが存在しない。

HIDのキーボードはあるものの、そこに通常ならあるはずの「管理タブ」がどこにもない。
まぁ触らなければいいやとそのときは簡単に思っていたが、復帰失敗につながるとなれば今更ながら調整しないとまずい。
つうか、電源スイッチが隠れていたり遠かったりする場合、キーボードとかで起動できないとはなはだ困ると思うのだが、vistaよ。
これが仕様なのか?

なぜタブがでないのかひとしきり悩んだが、もしかしたらUSBタイプのCPU切り替え機が問題なのではないかと思った。
特に疑う理由はない。
マザーのほかに更新したものと言えばそれくらいしかないからだ。
ps/2コネクタによる接続が一つしかないマザーなんて初めてなので、おかげでこれまで愛用してきたps/2タイプが引退となったわけだ。
これと思うのだが、どうすればよいか見当もつかない。
ところがあるタイミングでふとデバイスを見るとHIDキーボードが二つあり、片方はちゃんと電源の管理が出ていた。
この「あるタイミング」、これがわからない。
設定をいじったわけでなく、付け替えたわけでもなく、ただ時間の経過だけで、それも数時間後という取っつきのないタイミング。
原因不明です。
vistaは困ったやつです。
このまま17年まで付き合えるか心配になってきた今日この頃。 😡

vistaのスリープ設定はBIOSが要か

前回スリープの詳細設定を一度規定に戻してから、ハイブリッドスリープのみを解除してみたらスリープから復帰するのを確認できた。
しかししばらくしてまた復帰に失敗することに気づかされた。
どうやら数時間から半日程度の間スリープにしたままだと復帰に確実に失敗することがわかった。
原因切り分けの前提として、xpでは問題なくスタンバイから復帰できていたのに、vistaだと失敗するというのはそもそも間違っていた可能性が出てきた。
どちらのOSにしろ、長時間のスタンバイ、スリープは復帰できなかったのだろう。

そこでハード、特にBIOS(UEFI)を再度検討してみた。
asrockにはDDR3 power down(うろ覚え)という項目があって、これをデフォルト設定からenableに変更。
というのもasrockのマザーにはDr.debugという表示があり、復帰に失敗している状態では31が表示されたまま動かないでいる。
マニュアルで0x31の項目を当たってみればmemory installedと書かれている。
どうやらメモリー関連で遷移が止まっている様子。

Windows Vistaコンピュータのメモリをチェックする
念のためvista install DVDのF4で起動するメモリーチェックを数時間試すが問題なし。

さて、その後試してみたら半日でも問題なし。
24時間くらいではどうなのかはこれからチェック。

vistaのマザーボード載せ替え

[Vista] OS再インストールなしにマザーボード交換Vista編 速報版
以前もvistaのハード変更のことを書いた記憶があるのだが、今度はマザーの載せ替え。
機能も性能もいまいちなマザーボードからほどほど使えるマザーボードへと…。
ただのお下がりの有効活用なのではあるが。

今回とても楽だったのは690V → 785Gへ変更するだけだったから。
上記サイトのような操作は全く必要なかった。
ただマザーだけすげ替えるだけ。
あとは普通に起動すればよい。

初回各種ドライバーが勝手にインストールされるので、やるべきことはハードの変更によるウィンドウズの再認証をしなければいけないということぐらいか。

vistaでスリープの不具合

そういえば家族のパソコンでvistaが前から入っているのがあった。
ultimateなのだが、最近知ったが、サポートが来年(2012年)に終了するらしい。
となるとvistaに更新したばかりのパソコンはhome basicであるため、来年には7にアップグレードしないといけない。
もう一方のvistaはbussinessなので2017年まで延長サポートがあり、まだまだ使えそうだ。

xpでは「スタンバイ」を常用していた私。
であるからして、vistaでも当然ながら「スリープ」を使うことになった。
ところが、ultimateとbasicではスリープからの復帰に何の不具合もないのだが、bussinessに関しては復帰に失敗して、電源は稼働しグラフィックカードのファンは最大回転数で回り続け復帰しない現象にぶち当たった。
エディションによる違いとは考えづらい。
ハードに関してもごく最近発売された新型マザーであり、問題ないはず。
そこで気になったのが利用環境。
もっとも大きく違う点、それがログオン時のパスワード入力。
ほか2台はパスワードなしで自動でログインするが、復帰に失敗するものはパスワードが必要。

試しにコントロールパネルから「電源オプション」 「プラン設定の変更」 「詳細な電源設定の変更」 をデフォルト状態(「プランの既定に復元する」を押下)に戻してスリープを試行。
失敗。
次はハイブリッドスリープを無効にしてチャレンジ。
するとちゃんとスリープから復帰した。

ただ解せないのは、当初クリーンインストール後に試したとき、すでにパスワード必須であったが、ちゃんとスリープは復帰できていたはず。
そして動作しなくなったのは確か「詳細な電源設定の変更」からスリープに入る時間を設定してからだったはず。
つまりデフォルトでハイブリッドスリープが有効であったにもかかわらず動作していたはずなのだ。
これにより、ハイブリッドスリープが原因であると特定できないでいる。
動作するようになったのだから原因の一つであることは間違いないとは思うが。
まぁ原因不明の理由として、命短いvistaのために時間を割くのもばかばかしいというのもその理由のひとつなのではあるが…。

whsでvistaをリカバリ

whs2011が販売目前という遅いタイミングであるが、リストアについて。
vistaは重いし使い勝手がよくないので、プリインストール分も含めて4本あったが、すべて使ってこなかった。
ただ、ここに来てハードの進化により動作が重すぎるとまでは言えなくなったので、検証がてら変更してみた。

リストアに関しては他所でも書かれているので参照。
[FAQ]クライアント リストア 時のドライバインストール方法
ただ、私の環境ではlanドライバを読み込む際は、たしかxp用のドライバしかusbメモリには入れなかったはず。
上記サイトとはちょっと違うのが気になるが、追求してないので確認事項(2011に変更予定なのでやらないかも…)。

本来ならコンソールから復旧する目的のドライブをのぞくとWindows Home Server Drivers for Restoreフォルダが見える。
これをUSBメモリにでも入れておけばOK。
いや、だめだったからXP用のドライバを入れたんだった、思い出した。 😳
というのもベースのserver2003が出たときにはまだvistaはなかったはず、という推論で試したら正答だったから。

ともかく、vistaをリカバリするのであるが、リストアCDから起動、メモリ容量選択、ドライバ読み込み、復帰ドライブ指定などをこなせば復旧完了。
300G(実使用100G)のドライブなら予測で1時間(実際は30分強)で終了。

で、2台ほどリストアしたのだが、そのどちらもリストア後初回起動時に「正常にシャットダウンされませんでした」的な表示が出る。
当初「なんでかな」「そんなはずは…」と思ったので、もう一度違う日付のデータで復旧したがやはり表示されて、困惑した。
しかしよく考えれば、 😳 whsにバックアップ時はシャットダウンした状態のものでは当然ながらありえないので表示されて当たり前なのであった。 😳