GPTなHDDでマザー交換

5/29前後を境にWHS2011の自動バックアップ完了までの時間が倍以上かかるようになった。
イベントビューアでログを見ても直近で変化は無し。
原因不明のまま使ってきたが、Haswellが出たタイミングでサーバーPCをバージョンアップすることにした。

ピークは変わらずともアイドリングでivyよりも消費電力が下がっているそうなので、アイドルの長いWHS2011なら効果は期待できそう。
ただ、高性能なものは必要ない。
そうなると価格と性能の兼ね合いからceleronか、良くてpentiumになるのだが、haswell登場からまだ間もなく、celeron発売までしばらくありそう。
ATOMはSATAコネクタが2個までしか無く、HDDの接続を増やしたいのだが不可能。
USB3.0を搭載したものもあるが、CPUオンボードマザーの価格が跳ね上がる。それならばと、celeron 847は条件が良く値段もこなれていいが、後継の1007Uも気になる。
金額的に1007Uが候補なら、まだマザー単体では登場してない1037Uも待ってみたいところであり、こうなるともはや一本化できない状況に…。 😥

そこで、以前載せ替えで気に入ったG1610を考えてみた。
できればトランスコードができると良いのだが、これはもしできたらラッキー程度に思うことにする。
で、結果はG1610Tをチョイス。

マザーは遊んでいた前述のECSのものを使うことにした。
UEFIでGPT起動できるようになったので、WHS2011のHDDをそのままスワップ。
特段の問題もなく引越完了。
nosekae
インストールディスクからドライバーを当てて終了。

一方、これまた既述の、試しでECSなマザーで入れたwindows8.1なディスクもかつてのWHS2011マシンであるatom D525MWに付け替えてみたら、これまた問題なく動作。
HDDの付け替えだけで、GPTであることをBIOSで設定すれば特別意識せずとも動くようだ。
当たり前と言えば当たり前だが、気になっていたので。 😉

windows8.1 previewを試す

いろんなところで公開が伝えられたし、メールでもマイクロソフトから連絡有ったし、試してみようとは思っていたものの、アップグレードでは試す気にならなかったwindows8.1(blue?) preview。
それならば、とisoが出てから試してみようと半日ちょっと待機。

アップされたisoをDVDに焼いて、早速インストール。
これで新規クリーンインストールを試す。
今回は今後のサンプルのために1TBのHDDにわざわざGPTを設定して、UEFIからインストール。
当初インストールに使ったマザーは以前近所のユニットコム系列店で購入したECSの Z77H2-A3 (V1.2)
他の系列でもECS(他の板も)をよく見かけるので、たぶんBTOに使っていたものを何だかの理由で販売中止、それを取り外して単品で販売、ということか?
ECSが好きなのね。
この板、BIOSでは機械翻訳っぽい日本語も選択できるのだが、むしろ意味がわからん。
ともかくこれが初期BIOSのためか、UEFIから起動できない。
仕方ないので一度VISTAを入れて、BIOS更新。
eBLUを使用してアップデート。
一度OSを入れないといけないアップデートなんて面倒くさい。 🙁
他社のようにBIOSだけでできるようにして欲しい。

UEFIの画面が一新されて、ようやくUEFIからインストール可能に。
インストール時間はVISTAとあまり変わらず約20分。
起動。
welcome

早速スタートボタンが復活したかチェック。
shutdown
グラフィカルでないところが何ともミスマッチ。 😐
ただ、これで旧来のOSからのアップデートした人には取っつきやすくなるかも。
XPの期限を前にどうしても入れておいた方が良さそうだという判断だろう。

各所でwindows8とちょっとした違いが見受けられるが、取り立てて特に何も感じない。
確かにこれなら「8.1」だ。
所有のwindows8マシンは8.1が正式にリリースされてしばらく様子見してからアップグレード、だな。 🙄

閑話休題。
そういえばGPT起動ディスクを見たことがなかったな、と思いコンピュータの管理をチェック。
disk
回復パーティション?

SSDのSATA接続場所

SSDをシステムディスクにしておくと、CPUが多少古くて遅くても快適な動作を享受できる。
だからこそ今回初めて気づいた点。
SSDの接続場所は当初と同じSATA6Gのコネクタ。
crystaldiskmarkをSSDとHDD同時に実行。
before_3G

HDDをそれまでのSATA3Gのコネクタから6Gへ変更。
after_6G
どういう理屈か不明であるが、SSDのシーケンシャルリードの転送速度が向上している。

最大消費電力はいくら?

geforce GTX660
core i3 3225
P8H77-M PRO

消費電力を下げようと考えているものの一向にどうにもならない。
asusにはEPUなる消費電力を低下させる機能(チップ?)があるのだが、これも試してみた。
マザボ上のメカニカルスイッチを入れ、BIOSで機能を有効(Auto設定)。
しかし、アイドルでは73Wと全く変化なし。
動画再生時には 78w→76W と誤差程度の変化しかない。

反対に最大の消費電力量はどうか気になった。
いままでCPUフルロードくらいしか計測しなかったが、GPUも同時にやってみた。
ほとんどゲームをしないので、計測そのものが無駄でありエコではないのであるが…。

OCCT GPU 0FPS
Prime95
上記二つを同時に稼働。

200W弱でスタート後、ファンの回転とチップの温度上昇にともなって210W程度に上昇。
SSD+HDDなこの環境だとayakaze-300でも充分回るようだ。

ついでについ最近各所で見かけるようになったDQXのbenchmarkも試してみた。
dqx_bench

<2013.06.29追記>

PC版「ドラゴンクエストX」ベンチマークソフトを4GamerにUp。ドワーフ族の女の子による,傘にまつわる冒険をスコアと一緒に見守ろう

さらについでに、とあるタイミングで取り外したATOM D525MWでもベンチを試してみた。
が。 😎
全ての設定を試すも、起動すらせず…。
まぁ、こんなもんか。

熱対策で2種から1種へ

AMDの頃より発熱の少なくなった(はずの)intelメインPCであるが、夏を迎えようというこの時期にHDDの温度が少々気になり始めた。
かつてAMDのころは1種換気で給排気ともにケースファンを稼働させていたのだが、CPUからの熱量が減った(はずな)ので2種(吸気のみ)にしていた。
そのせいか、これまではトレイ常駐のcrystaldiskinfoのHDD温度表示で40度を上回ることはあまりなかったが、最近は43度くらいまで上昇する。

そこで再度1種へ変更。
以前よりも風量も音量も控えめな排気ファンを1機増設。
吸気は変わらずHDDラックを直接冷やす場所。
これでケース各所の解放部から漫然と排気されていたものが、エアフローのはっきりしたものに変わり&吸気の抵抗が減ったおかげで
43℃ → 35℃
とかなり下がった。
ノイズも以前と変わらない様子なので、これで良しとしよう。

いつかCPUクーラーの風を利用した導風板を作ってマザー全体の冷却も考えてみよう、などと思ったりして。 🙂
もちろんグラボなしのマザーに限ることになるだろうが、効果有りそうな雰囲気。

光学ドライブの消費電力

intel 1155の3画面出力でthunderbolt出力が必要と言うことで内蔵グラフィックの使用を断念。
そもそも4画面出力対応にはビデオカードを追加する必要があり、またkeplerの消費電力低下と4画面出力対応というタイミングで結局geforce GTX660に落ち着いた。
それでもアイドルで70W台なので、何とか下げられないかと考えた。

試しに、新しく発売開始された 1150のマザーボードの取扱説明書を見ると、thunderboltでなくても3画面出力できそうな気配を漂わせている。
だがマザーから一新する必要があり、また各所のアイドル時の消費電力ベンチでは低減していたりそうでなかったりとあやふやな感じで、費用対効果では新調する気にはならない。
3画面をthunderboltなしで構築できるなら興味深いが、1150マザーではthunderbolt搭載が見受けられない&thunderbolt対応製品が少ないなど、1150にしろ1155にしろやはり二の足を踏む。 😐

電源は80plus goldであるし、ストレージ以外は装着してない。
こうなると使用頻度からして、外せるのは5inchベイ搭載の内蔵光学ドライブくらいのもの。
そこでDVDとBD(リードのみ)の消費電力を計測。

参考に旧世代のATAPI接続のCDも一緒に計る。

DVD
iHAS524

BD
iHOS104

CD
CD-950E

それぞれディスクを未挿入状態でOS起動後しばらく後のアイドル状態。
なお、ACアダプタ経由でドライブのみの電力量を計測。
そこにワットモニターを挟んで読む。
ACアダプタのみを接続した状態では、0.8W。

DVD 1.8W

BD 1.1W

CD 4.8W

起動電流などがあるので-0.8と単純に言えないが、新しいドライブは非常に消費電力が低い。
最近はアイドル時の消費電力低減を謳うドライブが多数あるので、新しければ新しいほどよさそうである。
逆に古いものはリプレイスあるいはUSB接続化することで消費電力を押さえることができそうな雰囲気。

もし電力が大きいならマイナスコントロールで電源コードにスイッチをかませて、BIOSでホットプラグ対応設定にすればいいかと思っていたが、これはもはや誤差程度でしかない。
ま、これくらいなら別にいいけど。 😉

遅くなったtmpgenc vmw5

先日ようやく
Ver.5.3.1.85

Ver.5.3.4.96
に更新した。

取り立てて不満はないし、何より「・x264エンコーダーを更新しました。」という更新内容も気になっていたからだ。
しっかり前後を確認してみたいと思っていたからだ。

で、実時間15分程度の動画をいつもの264なmp4ファイルにエンコ。
12.18(分、秒)

12.56
と数%ほど時間がかかるようになった。
そんなわけで更新当初はまぁこれくらいなら別にいいかって感じだったが…。 😐

phenomなエンコマシンで私の設定の場合、バッチ処理で2個同時までが有用な使い方だったのだが、数%ではないほどの時間がかかるようになってしまった。
感覚的には1.2~1.4倍程度時間が上乗せになった感じか。
128GBのSSDに入れた動画が深夜電力時間帯に終了できていたのが、現在完全に足が出てしまった状況。

で、調べたら、あった。
TVMW 5.3.4.96になってエンコード遅くなりました?
中でも「設定」のところで、1パスと2パスの違いがあるのでは?というところが気になっている。
何せ私も以前のバージョンの設定を覚えていない…。
というか、今更バージョンアップする遅さであるなら、エンコーダ更新がどうだったのか先に調べておくべきだった。 🙄
この記事、先に読んどけば…。

試しに1パスにしてバッチの並列処理を試してみようと思う。
なんだよ、比較用のプロジェクトも動画ももう消しちゃったよぉ…。 👿

<2013.06.08追記>

設定を1パスにしても変化なし。
そもそもエンコードで1パスを指定していたので、まぁ当然と言えば当然か。
友人の方(同じエンコ設定)でも試してもらったが同じエンコード時間という結果。
となれば、うちのエンコ設定の場合だとエンコーダーの更新自体の方が結果に関連あるということだ。

CPU負荷率に注視していると、以前は100%張り付きだったのが、80~90のあたりをふらついている。
バッチ処理で2個並列の場合もやはり100%だったものが、100弱くらいになっており、さらに23.976fpsなもの二つ同時エンコの場合に至っては何故だか80%前後の使用率。
以前なら100%張り付きだったが…。
仕方ないので現在は同時処理数を2→3に変更している。
今のところこれで以前と同じ時間で終わっている様子っぽい…。
ただし、正確な比較ではないので自信なし。 😥
プロジェクトを継承できない(更新履歴に記載)はずなので、ダウングレードしてエンコ時間チェック(プロジェクト保存)してから、アップグレードしてまたチェックという手間を惜しまなければ試せるが、しばらくは現状を静観しようと思う。

<2013.07.17追記>

現在の最新verが5.4.0.100。
割と短いスパンで出てきたので、対処されたのかもと思いリリース直後にテストした。
それの記録。
5.4.0.100
5.3.4.96
5.3.1.85

version

同じハードウェア構成で、同じファイルを同じ設定でベンチ。
CPUはいずれもほぼ100%。
変換元ファイルはTSファイルで、カット編集後の時間がうろ覚えで確かではないのだが、5分ジャストのもの。

以下pegasys更新履歴より
><不具合修正>
>・Ver.5.3.3.95以降でインタレース解除やリサイズ、または時間軸映像ノイズ除去が使用されている場合に出力速度が低下する問題を修正しました。

エンコ設定で「必要な場合インタレース解除」を有効にしているので、これが影響したものと思われる。
100はむしろ以前より早く終わっている。(ただし、マスターが短いためにこれが確証とも言えないなぁ)

上記結果から、現在は100で稼働中。 😉
ちなみに…、

以下pegasys更新履歴より
><機能更新>
>・TSファイル詳細読み込み時に、異なる音声チャンネルモードが混在している DolbyDigital 音声のデータを認識するようにしました。

以前までのverでは同じTSファイル内であるにも関わらず、5.1chの時に数コマほど2chになる現象にたびたび見舞われたが、手元にファイルがないので対処されたか不明。
そのまま結合して5.1chとして出力するとつなぎ部分で数コマぶっ飛ばされるので、仕方なく今まではTSを6chとして扱うことで回避していたが、もし改善されたのならうれしい。

<2013.07.31追記>

残念ながら、相変わらず異なるコンテンツと判断されることが多いようだ。 🙁

w8 OSの再インストール

ソフトウェアの挙動がおかしくなり、レジストリをチェックしていたところ、削除できない事案に遭遇。
レジストリの削除ができない、リネームも値の変更も、何よりアクセス許可がない、何をしようがともかく削除させてくれない。
クリーンアップするソフトもあるようだが、可能かどうか疑問。 😐

それにアップグレードでwindows8になった時からキーボードが勝手に英字キーボードに変更して認識されたまま、などというアップグレードに伴うものと疑われる不具合もあったので、このレジストリ削除不能というのもアップグレード時からのものだったのかも知れない。
今ではもうわからないが…。

レジストリを変更できないと動いてくれないので、仕方なく再インストールを決意。
アップグレード版なので2回インストールしないといけないのかと思うと憂鬱…。

しかし、実際PCに入っているwindows8をアップグレードするという形で、一回のインストールで完了した。
当然クリーンインストール。
キーボードも正常、レジストリも問題なし。

ちなみに、media centerを入れていたので、「システム」で表示されるプロダクトIDはmedia centerに対するもので、windows8のものと異なる様子。
おかげで、当てずっぽうでチャレンジすることとなった。
かつて使ったことのあるプロダクトIDレスキューソフトはwindowsの「悪意のあるソフトウェアの削除ツール(だったか?)」により使えなくなってしまい、仕方なく別のソフトを試してみようと思ったらスタンドアロンでは使わせないという不安な仕様のものだった。
そもそもmedia centerのIDを表示って…。 😐