超速ファイルコピー

windows8.1 pro 64bitなPCで気づいたこと。
update1は適用済み。
転送速度
転送速度が異常に速い。
てか、おかしい。
正確には表示がおかしい、というべきか。
転送先HDDはしばらくアクセスランプがつきっぱなし。

ネットワークストレージから外付けHDDにファイルコピー、その後外付けから内蔵HDDへファイルコピー。
内蔵HDDへのファイルコピーの際に発生する。
つまりは同一ファイルの場合はバッファされているということだろう。
リソースモニターによるとコピー完了まで内蔵HDDはフルロード中。
転送元の外付けHDDの状況を確認してないが、もしファイルコピーでなく移動だとしたら、安全な取り外しなしでプラグアウトしてもいいのだろうか?
予期せぬシャットダウンなどを考慮すればアウトだと思うが…。 ❓
もちろん元ファイルが削除されていなければ存在が担保されているといえるが、それはそもそも動作表示として整合性が合わないのでは?
わからん。

気になったので調べてみるが、情報があまりない。
HDDなのにファイルコピーが500mb/sで即完了
似ているので、update1の適用は関係ないのだな。

<2014.4.18追記>
リソースモニターでコピー先にコピー動作中を確認し、試しでコピー元の外付けHDDを外してみた。
物理的にではなく、「安全な取り外し」により、である。
するとコピー中でも「取り外せます」。
…。

やはり途中で動作が固まったりしたらやばそうである。

スリープ嫌がる、の続き

windows8.1 64bitにしてからもスリープをしない現象に苛まれている。
これはもはやハードウェアに依拠する何か、ということにして目をつむりたい気分。
選択肢として、windows8に戻してしまうという手もありかと考えていたのだが、しばらくすればwindows8.1 upadate1がリリースされるからそれを試してからでもイイか、と…。

そして昨日windows updateから更新可能になったので、即実行。
感触としてはいい感じ。
当てる前後で、スリープに移行する確度が格段にアップ。
これは同時に、スリープにならない場面にも遭遇したことを示すのだが…。 🙁

まとめることがいろいろあるが、まずは明らかな変化から。
外付けHDDのgoflex freeagentの動作ランプ。
なお、このPCでは昔から必ず電源オプションの設定で、HDDのスリープは「なし」にしている。
これ、update1の前までは自動でスリープになっていた。(動作ランプが消灯)
今では、スリープ復帰後の消灯継続を除き、常に点灯している。(動作ランプは点灯したまま)
外付けHDDのスリープ制御が本体の設定に準じるようになった、と推測。
この動作が関連するのかどうか不明だが、HDD接続時、以前(32bit & update1適用前64bit)ではスリープにならない可能性が比較的高かったのに、現在は100%スリープとなる。(追記:まれにスリープにならず、95%くらいか)

一方で、場面は少なくなったものの、スリープにならないこともある。
他の外付けHDDを使っている場面がそれだ。
何故だか今までスリープ成功していたHDDで嫌がるようになった。
接続頻度が少ない上、付随していろいろソフトを動作させているので何が原因か、まだ不明。
これはもっと見続ける必要があるようだ。 😥

次は、過去の案件から。
かつてwindows8.1 32bitの際は、オプション扱いだったKB2919394なのだが、今回windows8.1 64bit(現時点)では当初より重要な更新に含まれている。
これ、32bitの際は当ててしまうと当PCだとスリープしない、それどころか設定時刻後にスクリーンをオフにする設定自体が働かなくなる現象にぶち当たる。
スリープを確認するために、スクリーンオフ1分、スリープ1分、と設定してある。(調べ始めてからなので、すでに半年近くになる)
当時、3度ほど当てたりアンインストールしたりして確認したので、おそらく原因に違いない(と思う)。
思うのだが、ネットを調べても似たような件は出てこないので、あくまで当PCだけなのかもしれない(とも思う)。
しかし、それを思い出してupdate1を当てる前に、KB2919394を当てたりアンインストールしたりしてみたが再現性がない。(スリープになるときも散見)
あくまでwindows8からアップグレードした8.1な32bit、かつ当PCで起こったまれな現象なのかもしれず。

そんなわけで未だ継続中。
…。
何か、ばかばかしい…。 🙄

<2014.4.18追記>

まだ主要ソフトをインストールしていない、データ的に比較的軽い状態なので、試しでwindows8をインストールしてみた。
そしたら、windows8でもプリンターの自動インストールは有効だった。
(あれれ、これ、別件で書いた話か…。)
ただし、windows8.1だと速やかにプリンターのインストールが完了するのに、windows8だとかなりの時間(5分くらいか?)かかった。
それに、ハードウェア的には全く同じなのに、全体の動作がやや緩慢。
同じOSとして見ていて、その実ごくわずか遅く感じるというのは確かに何かが違うのかも知れない。
おそらく画面表示だとか、画面遷移とか、そういった部分だろうと思われる。

そういう話は機会があればまたいずれ…。
で、主題のスリープ。
1分スリープ設定にして通常行う(頻度の高い)作業を繰り返し、スリープ移行を幾度と繰り返す。
そしたら現象発現。
デフォルト設定でも、ソフトをインストールしていなくてもなるようである。
となると、これはwindows8に関連したことに違いない。

早速whs2011にバックアップしてあったwindows8.1(update1)を元に戻して、プロセスチェック。
こうなったら人海戦術、いや、人手はないからしらみつぶしである。
プロセスを強制終了してスリープするか確認する。
作業を繰り返しスリープしなくなったら、まずは数個をまとめてプロセス終了。
当たるまで繰り返し、当たったら、次は(再起動してスリープしなくなったところで)個別にプロセス終了。
すると、host process for setting synchronization を消すとスリープすることに行き当たる。

はて。 ❓
これなに?
What is “host process for setting synchronization”, and why is my firewall blocking it?
調べても確実な情報には行き当たらず。
サービスを確認するもわからず。
ともかく上記を信じて「設定の同期」の全てをオフに。
結果、該当プロセスが出現するまでの時間はかなり長くなったが、消えるわけではないようす。
何かのタイミングで出現。 🙁
まだ解消していないが、少なくともスリープしなくなったときに該当プロセスを終了すると、今のところ100%スリープするのは事実。

もぅちっと様子見か…。 😡

<2014.4.20追記>

どの段階だったか、ここ最近「安全な取り外し」が実行できない。
torihazusi
update1(KB2919355)適用後だったか、あるいはその数日後の再パッチ(実際はKB2959977)だったか、ともかく上記のように。
試しの外付けHDD3台ともこんな感じ。
そもそも高速化云々はしてないのでそのままプラグアウトしているが、どうにも…。 😥
スリープ制御は良くなった(表示LEDが適正)のに。
windows8はタブレットを意識してか、それとも最近の流れか、省電力に注力しているのだろうが、どうにもふらつくイメージ。
ちなみに、個人的にはw2kが一番印象良かった。
あ、内容的には別記事だが、流れ的に外付けHDD関連なので続きで記載。

本題のスリープに関しては、やはりhost process…を切る(動作的にはスクリーンオフ時に再起動される様子)ことでスリープ移行になる。
今のところのスリープ移行再現性は100%。
まぁ、以前(update1適用前)より発現は確実に低確率になっているので実施はまだ5回くらいなのだが…。 🙄

<2014.4.26追記>

one driveを無効にしてみようと画策。
Onedrive (Skydrive) を無効にする方法
すっかり項目名を忘れてしまったが、上記の該当項目には3項目あり、上記はそのうち一つをターゲットにしてあるが今回は全て”いいえ”を「有効」にした。
そしてone driveに唯一保存されていたdesktop.iniを削除。
いつの間に保存されたのか知らないが、ともかくインストール直後なのに壁紙が自動で復元される時点でアカウントに同期が取られていることに気づくべきだったな。 😡
しかし、一度もskydriveを有効にしたことはない…、はずだが。

マイクロソフトアカウントに関連づけしてあるメールアドレスがログインアカウントとして使ってきたのだが、アカウントに保存してあるためだろう、インストール直後でも背景(壁紙)がいつものものになっていた。
本来的には他のPCでも同じ作業環境を再現できるように、ということだろうが、よくよく考えればグローバルアカウントにする必要はそもそも私には無かった。 🙄
何せクラウドを信用していないので…。

で、経過観測していたのだが、host process…は変わらず出てくる。
そしてスリープ移行しないときはこれをタスク終了するとやはりスリープになる。

ならば一方の可能性である「グローバルアカウントをwindows7までのようにローカルアカウントにする」ことにしてしまおう。
ということで、現在はローカルアカウントで運用中。
以来host process…もプロセスに出てこないので、ひとまずは良しとして様子見。

ついでにここに書いてしまうが、以前windows7からアップグレードしたPC(windows8.1 pro 32bit)では、外付けHDDを使うとデスクトップアイコン&背景が暗転する不具合があったのだが、クリーンインストールしたwindows8.1 pro 64bitでは一度も再発しない。
インスト直後でも、update1の適用前後でも関係ないし、おそらくクリーンインストールしたおかげだろうと推測。

更についでに、前回追記の「安全な取り外し」の件。
動作を見ていると、どうやらwhs2011の監視対象になったタイミングでなるように感じる。
バックアップのカスタマイズでどうにかなりそうな気がしているのだが、物理的にプラグアウトして問題ないので、これの検証はしないつもり。

<2014.5.2追記>

安全な取り外し、最近は出なくなった。
再現できないと検証できないのだが…。
ま、検証しないつもりだったわけだし、良しと思うべきなのだろうが。
振り返ってみても、バックアップのカスタマイズをしたわけでなし、思い当たるところがない…。
現状うまく「安全な取り外し」でプラグアウトできているので良しとしよう。
釈然としないが…。

で、本題。
以来順調にスリープになる。
外付けHDDの動作は正常になっているようだし、結局ローカルアカウントが解だったということか。 🙄

SPH-DA05にipod

急遽予定変更で、SPH-DA05でのタブレットの使用をあきらめた。
その経緯はまぁ、後日として。

とりあえず、CD-HUV220のUSBコネクタにiPod touchをUSBケーブルで接続。
SPH-DA05で「iPod」にアクセス可能に。
iPodに収録の音楽再生は可能な様子。
ビデオも可能だが、映像が出ない。
だが、最大の問題点は音声がスピーカーから出力されないこと。
おー、だめじゃん。 😥
まったくもって使い物にならん。

やはり対応の純正ケーブルを使用しなければならないのか。
CD-IUV220を購入。
ケーブルごときにこんな投資をするのは腹立たしいが、動かないのはもっと嫌。

そして購入したケーブルを比較。
コネクタの違い
HUVの方のコネクタはIUVのコネクタより活きたピンがはるかに少ない。
前者4+1に対して、12+1の信号線がある。
USBコネクタの方を調べてないのでわからないが、同じピンアサインだと仮定すれば、IUVでHUVを包含(下位互換)できる。
HUV220のUSBケーブルの方をIUV220のものにしてしまえばいいじゃん。
量産効果でるんじゃね?

ま、それはともかく。
前回はタブレットを接続しても充電できなかったはずだが、何故だか今回は両ケーブルとも充電できていた。
前回も何度も試したのに…、よくわからん。

今回はCD-IUV220でiPodを接続し動作確認するのが目的。
これも接続時充電されている。
そして動作確認。
スピーカーからも音声が出力される。
SPH-DA05から曲をサーチして選曲できるのだからひとまずは目的達成か。
なお、動画は試していない。

一連の経緯を考えるに、SPH-DA05を買うメリットとは、iPodやiPhone、タブレットやiPadにスマホを持っていて、そのデバイス(コンテンツ)を車内でも使いたい場合に限られる。
SPH-DA05のために各デバイスを揃えるのは本末転倒だし、ナビとかミュージックサーバー等の単体性能で考えると単純にカーナビの方が合理的。 😉

windows8.1でプリンタドライバを当てる…、必要ある?

実は前件でリストアしたのは、windows8.1なメインPC。
32から64に移行して特段問題なさそう。
まだソフトのインストールも周辺機器のインストールもまだなので確定ではないが…。

さて、そんなクリーンインストールなwindows8.1 64bitだが、何故だか以前と同じようにスリープが阻害されてしまうことがある。
クリーンに近いのに…。
逆説的に対象が絞りやすいということでもある。
一つずつ見ていくことにした。

で、検証する上で最も引っかかったのがプリンター。
canon MP560という複合インクジェットをwifiで共有して使用している。
これを使った後、スリープにならないことがあるようだ。

経緯を思い出す。
他のソフトを入れる前から必要に駆られて、canonからドライバーを落としてインストール。
以前の32bitの時もそうだったが、「デバイスとプリンター」には該当のプリンタが二つ表示され、片方はグレーアウトしている。
そもそも二つ表示されるのはおかしいと思い、プリンターの電源を消し、ドライバーを削除してみた。

すると、両者とも消える。
再度チャレンジなわけだが、今度はしばらく様子を見てみる。
二つ当たってしまう理由を見たいがためだ。
プリンターの電源を入れて、約30秒、なにがしか動き(メインのプリンタ表示が消える)が見られる。
更にその30秒後にはドライバーが自動で当てられた。
何もせずともいいのかよ…。
しかも、「ネットワーク」を表示させると、今まで見たこと無かったネットワークデバイスに「スキャナ」が表示され、MP560が並んでいる。
ネットワーク
他にも「多機能デバイス」とあるし。

これだと、わざわざcanonのドライバーを当てる必要は感じられない。 😕
ソフトは使えないだろうけど、使わなかったので必要性は感じなかったし。

それと、プリンターがアイドリングになるとプリンター本体の液晶表示が消灯する(5分くらい、かな?)のだが、32bitのときは消えたと思ったらすぐ再点灯というのを繰り返していた。
現在はアイドル中で消灯したまま。
それでもwindows8の時はそれで問題なかったわけだから、アップグレードの過程で何か不具合があったのかもしれず…。

これがスリープ阻害の原因とは言えないが、現状再発、再現が見られない。
しばし様子見。

UEFIをリストア

前件でUEFIなシステムをバックアップできるようにした。
で、実際にちょっとした事情でWHS2011からリストアすることに…。

まずはリンク先にあったようにキー回復のUSBを作成。
サーバにUSBメモリーを刺して指示通りに。

それをリカバリするPCに刺して、UEFIでUSBメモリーからブート。
USBメモリーは早くていいな。 😉
で、最初はドライバーの入ったCD(マザボメーカーのCD)を挿入してネットワークドライバを当てようとしたが当たらず…。
改めてwindows7 64bit用のドライバをUSBメモリーに入れて再試行。

今度は順調に進む。
UEFI
途中、上記のように目新しい項目が出たが、推奨のまま実行。
簡単にリストア完了。

たままただったが、リストアできることが確認できたので良し。 😮